Item Treasury

Item Treasury 0Item Treasury 1
Item Treasury
Автор оригинала:
Galuhad
Автор перевода:
Чирик
Версия:
23.2 (rus b1)
Поддерживаемая версия клиента:
Русский, Оригинальный

Описание возможностей плагина:
Item Treasury — тот самый плагин который способен помочь российским игрокам с доступом к аукциону. Это достаточно широкая (более 100 тысяч) база предметов, разбитых на категории. Названия предметов переведены на русский язык, что позволяет использовать поиск на русском языке для нахождения нужного предмета и получения оригинального названия.

Оригинальная версия плагина: здесь

Команды
/item - показать главное окно
/item <id/название> - отобразить список искомых предметов

Как установить плагин:

а. Перед тем, как устанавливать сам плагин, убедитесь, что у вас создана папка Plugins по пути:

%USERPROFILE%\Документы\The Lord of the Rings Online

б. Убедитесь, что у вас скачаны и установлены библиотеки плагинов от Turbine.

1. Распаковать архив в папку по пути:

%USERPROFILE%\Документы\The Lord of the Rings Online\Plugins\

Как запустить плагин:

Запустить плагин можно тремя способами:

  • Через стандартную комманду загрузки плагинов /plugins load itemtreasury
  • Через встроенное Управление Плагинами от Turbine
  • С помощью плагина Shady

FAQ:
"У меня ничего не работает? Что делать?"
Перед заходом в игру удалите файлы ItemTreasury_Settings.plugindata в папке по пути:
%USERPROFILE%\Документы\The Lord of the Rings Online\PluginData\<имя аккаунта>\<имя сервера>\<имя персонажа>\
Затем зайдите в игру и попробуйте загрузить плагин.

Если это первый ваш плагин, то внимательно прочитайте "Гайд по плагинам".
Внимательно прочитайте шапку данной темы и выполните все пункты последовательно, обратив пристальное внимание на пункты "Как установить" и "Как запустить".
Если не выходит, внимательно прочитатайте раздел "FAQ".
Если все равно ничего не вышло, то Вам следует задать вопрос в этой теме. 

"Я загрузил плагин, но ничего не появилось. Не могу открыть плагин."

Окно плагина открывается командой /item

"Я не могу загрузить плагин, хотя это уже не первый мой плагин. Все работают, а этот - нет."

Если плагин не запускается никакими средствами, либо какие-то его функции не работают, значит, в чат должна выдаваться ошибка. Поставьте в настройках чата, в фильтрах, галочку напротив строки "ошибка". Скопируйте текст ошибки из чата в эту тему. Специалисты попробуют разобраться и помочь Вам. И не забывайте, что Вам никто ничего не должен.

"Где кнопка плагина?"

Функционал кнопки для данного плагина не предусмотрен.

Благодарности
Спасибо Galuhad за столь замечательный плагин!
Скачать:
VindarPatch
(14.6 КБ)
+14
06:14
2299
09:57
*Бьет челом за столь чудесный костыль*
12:29
+1
По оплошности ранее пропатчил его виндарпатчем. У кого будет ругаться, докачайте еще и его. Я временно прикреплю его под плагином.
09:29
Первый раз плагины ставлю в лотро. Выдает ошибку Failed to import package «GaluhadPlugins.ItemTreasury.Utils. Как ее решить можно?
12:44
+1
Возможно вы некорректно распаковали плагин. Проверьте. Ваш путь должен выглядеть так:
%USERPROFILE%\Documents\The Lord of the Rings Online\Plugins\GaluhadPlugins\ItemTreasury
И в этой папке уже скрипты плагина.
Так же проверьте что у вас скачаны и установлены библиотеки турбины из пункта б) «как установить»
16:36
+1
Я смотрю достаточно много плагинов уже адаптированы под русификацию.
Не возникало мысли, добавить возможность их установки и обновления через Наследие, по примеру «lotro compendium»?
09:28
Возникало, но разработчик сейчас очень занят. Возможно летом подумает над этим, но там еще планы по выпуску второй версии Лаунчера.
08:28
+1
Огромное спасибо, Вам, за ваши труды! Поставила, опробовала, в большом восторге) Низкий поклон, Вам!
10:35
Online\Plugins\GaluhadPlugins\ItemTreasury\Main.lua:1: Unable to resolve package «VindarPatch.Patch». Вот такую ересь в игре пишет, подозреваю что неправильно пропатчил… прошу помощи
23:49
А что там патчить? При установке библиотек lua и самих плагинов ничего патчить не надобно. Возможно, Вы не изучили инструкцию по установке плагинов (забыли/неверно поставили библиотеки, необходимые для работы плагина). Либо некогда у Вас уже стоял подобный плагин другой версии, а значит требуется очистить данные в папке PluginData.
17:18
Когда пытаюсь загрузить плагин, он выдает вот такую штуку — "… Online\Plugins\GaluhadPlugins\ItemTreasury\Main.lua:82: attempt to call field 'GetClientLanguage' (a nil value)". Подскажите плз, как решить проблему?
23:45
Плагин не может определить русскую локаль игры, что могло быть вызвано несколькими причинами: отсутствие русификации клиента, плохая русификация клиента (с ошибками) или устаревание «костыля», который заложен в коде плагина. Проверьте, переведена ли у вас эмоция "/чирик".
15:41
Не нахожу такую эмоцию. Русификация через лаунчер Наследия ставилась. sad
00:09
В оригинале она называется chitter. Попробуй поставить готовый русифицированный файл:

Русифицированный client_local_English.dat (от 13.11.2019)
Обновление 25.0.1 (dat файл перекачен, патчи русификации применены заново)

Установка:
— скачать файл по одной из ссылок ниже
— перейти в папку с игрой
— вставить с заменой скачанный файл client_local_English.dat
— запустить лаунчер Наследия для входа в игру

Google Drive — drive.google.com/open?id=1MAdhfNZiowscYVgLOrZnH4Jqp0yMV8Vf
Yandex Disk — yadi.sk/d/tysMSgPNMRaaSg
08:31
+1
обе ссылки не работают((
16:21
Перезалив был в связи с хотфиксом.
16:32
Прошу прощения, но не совсем понял. Что делать? Просто еще раз попытаться?
20:05
#Rudat_ВКО Русифицированный client_local_English.dat (от 21.11.2019)
Обновление 25.0.2 (dat файл перекачен, патчи русификации применены заново)

Установка:
— скачать файл по одной из ссылок ниже
— перейти в папку с игрой
— вставить с заменой скачанный файл client_local_English.dat
— запустить лаунчер Наследия для входа в игру

Google Drive — drive.google.com/open?id=1TiCqEFzNgHy3XLfy3QckUwwcrRKMKjuM
Yandex Disk — yadi.sk/d/x88RCqsg5tq2cg
22:10
+1
Спасибо большое, помогло!